On 09/14/2015 07:54 PM, Richard Sandiford wrote:
This patch splits optabs up as follows:
- optabs-query.[hc]: IL-independent functions for querying what a target
can do natively.
- optabs-tree.[hc]: tree and gimple query functions (an extension of
optabs-query.[hc]).
- optabs-libfuncs.[hc]: optabs-specific libfuncs (an extension of
libfuncs.h)
- optabs.h: For now includes optabs-query.h and optabs-libfuncs.h.
This seems like a good change.
I changed can_conditionally_move_p from returning an int to returning
a bool and fixed a few formatting glitches. There should be no other
changes to the functions themselves.
I'm taking your word for it. The patch is slightly confusing in one area
of optabs.c (it looks like debug_optab_libfuncs got moved around, it
might be better for patch readability not to do that).
The only thing I really wondered about...
--- /dev/null
+++ b/gcc/optabs-tree.h
@@ -0,0 +1,45 @@
+
+#include "optabs-query.h"
I haven't quite followed amacleod's work on the #includes, so I wasn't
quite sure whether headers are supposed to include other headers these
days. But as far as I can tell that's fine, So, patch ok.
Bernd