This patch makes us use type-generic built-ins for isfinite(), isnan(), and signbit(), through their “safe” definitions in libgfortran.h, rather than manually handle the suffixed variants (isfinitef/isfinite/isfinitel/finiteq, and the like). This reverses the patch that originally introduced this suffix handling (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=57496), because the built-ins have since been made type-generic in the C front-end (the last one last week, by me).
This is an improvement in code readability and size, and might also yield minor performance gains: the built-ins are expanded inline, rather than requiring a function call. Bootstrapped and regtested on x86_64-apple-darwin15. OK to commit to trunk? FX
float.ChangeLog
Description: Binary data
float.diff
Description: Binary data