https://gcc.gnu.org/bugzilla/show_bug.cgi?id=114907
--- Comment #4 from H.J. Lu <hjl.tools at gmail dot com> --- (In reply to H.J. Lu from comment #3) > convert_mode_scalar has > > if (GET_MODE_PRECISION (from_mode) == GET_MODE_PRECISION (to_mode)) > /* Conversion between decimal float and binary float, same size. */ > tab = DECIMAL_FLOAT_MODE_P (from_mode) ? trunc_optab : sext_optab; > > Since for HF->BF, DECIMAL_FLOAT_MODE_P (from_mode) is false, tab is > sext_optab > and __trunchfbf2 should be renamed to __extendhfbf2. Since BFmode range is bigger than HFmode, __trunchfbf2 should be used.