Looks nice, just what I needed two weeks ago and partly had
to implement myself :-)
But, I would recommend to stick with the ususal naming of size dependend
things, by appending a numeric suffix. Something like:
int mb_get8(struct mbdata *mbp, u_int8_t *x);
int mb_get16(struct mbdata *mbp, u_int16_t *x);
int mb_get16le(struct mbdata *mbp, u_int16_t *x);
int mb_get16be(struct mbdata *mbp, u_int16_t *x);
int mb_get32(struct mbdata *mbp, u_int32_t *x);
...
Using 'word' and 'doubleword' is rather confusing (when speeking of words
I would think of 32 bit nowadays).
harti
--
harti brandt, http://www.fokus.gmd.de/research/cc/cats/employees/hartmut.brandt/private
[EMAIL PROTECTED], [EMAIL PROTECTED], [EMAIL PROTECTED]
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-net" in the body of the message