On Mon, Mar 17, 2003 at 12:43:19PM -0800, Crist J. Clark wrote: > On Mon, Mar 17, 2003 at 09:11:12AM -0800, David O'Brien wrote: > > On Mon, Mar 17, 2003 at 12:28:34AM -0800, Crist J. Clark wrote: > > > +kldxref_start () { > > > + if [ -z "$kldxref_module_path" ]; then > > > + MODULE_PATHS=`sysctl -n kern.module_path` > > > + else > > > + MODULE_PATHS="$kldxref_module_path" > > > + fi > > > > Please change the logic to positive logic: > > > > if [ -n "$kldxref_module_path" ]; then > > MODULE_PATHS="$kldxref_module_path" > > else > > MODULE_PATHS=`sysctl -n kern.module_path` > > fi > > Is there a technical reason for that or is it just a "style" issue?
Style, easier to read out loud, easier to understand w/o having to think. Just like this is hard to "read". It certainly doesn't do what one reads out loud: "if not string compaire equal". if (!strcmp(a,b) { printf("same\n"); } To Unsubscribe: send mail to [EMAIL PROTECTED] with "unsubscribe freebsd-current" in the body of the message