On 15 April 2016 at 17:22, Conrad Meyer <c...@freebsd.org> wrote: If you implement a new IO scheduler you can name it whatever you like. > "NG" isn't any more meaningful than "Netflix." >
True, but _NETFLIX as a suffix is bad for three reasons: 1st- it creates a precedent for every sponsoring co. to want their name in the kernel space. 2nd- I doubt any other company would want to sponsor improvement of _NETFLIX codebase, and at the same time after how many commits does the code become so remote from _NETFLIX code so as to have _NETFLIX become a meaningless piece of nostalgia? Finally, taking a leaf out of McConnell's Code Complete- variables need to have an unambiguous and meaningful name- what on earth does _NETFLIX mean: "to be only used at netflix", "to be used on netflix hardware", "to be used with netflix's permission", or something else- if you need to look it up, the variable is named wrongly! My 2c. Cheers, -- Igor M. _______________________________________________ freebsd-current@freebsd.org mailing list https://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"