on 09/11/2010 10:02 Alan Cox said the following: > The kernel portion of the patch looks correct. If I were to make one > stylistic > suggestion, it would be to make the control flow of the outer and inner loops > as > similar as possible, that is, > > for (... > if ((pdp[i] & PG_V) == 0) { > ... > continue; > } > if ((pdp[i] & PG_PS) != 0) { > ... > continue; > } > for (... > if ((pd[j] & PG_V) == 0) > continue; > if ((pd[j] & PG_PS) != 0) { > ... > continue; > } > for (... > if ((pt[x] & PG_V) == 0) > continue; > ... > > I think this would make the code a little easier to follow.
This is a very nice suggestion, thank you. Besides the uniformity some horizontal space is saved too :-) Updated patch (only kernel part) is here: http://people.freebsd.org/~avg/amd64-minidump.5.diff -- Andriy Gapon _______________________________________________ freebsd-current@freebsd.org mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-current To unsubscribe, send any mail to "freebsd-current-unsubscr...@freebsd.org"