https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=298809

--- Comment #1 from Adrian Palmer <[email protected]> ---
Worth noting explicitly:

moving the addresses to a paired /31 on the VM side of the bridge fixes the
route.


Additionally, I have confirmed this behavior on Juniper routers (which use the
FreeBSD kernel).  Create a route that passes through a singular /32 nexthop
fails (silently) with:

 rpd[1998]: RPD_KRT_Q_RETRIES: nexthop ADD: Operation not supported
** IOW: route not installed in route table, despite route being explicitly
defined in config.

Again, setting this link to paired /31 addresses fixes the problem.


So to re-characterize, the kernel does not allow a stub network (the network
behind a /32 entry) to be a routeable network; and fails with undefined state. 
A /32 nexthop is not allowed by the kernel behavior - again, accepting it and
failing.

This *might* be legitimate - but not illegal per RFC - but documentation and
error are lacking in any state.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Reply via email to