>Number:         169657
>Category:       kern
>Synopsis:       [dtrace] name clash between dtrace and geom.h
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Thu Jul 05 09:50:07 UTC 2012
>Closed-Date:
>Last-Modified:
>Originator:     W.L. Tai
>Release:        9.0 stable
>Organization:
>Environment:
>Description:
provider is a reserved word in dtrace but it is also the name of a member of 

struct g_geom {
        char                    *name;
        struct g_class          *class;
        LIST_ENTRY(g_geom)      geom;
        LIST_HEAD(,g_consumer)  consumer;
        LIST_HEAD(,g_provider)  provider;
        TAILQ_ENTRY(g_geom)     geoms;  /* XXX: better name */
        int                     rank;
        g_start_t               *start;
        g_spoiled_t             *spoiled;
        g_attrchanged_t         *attrchanged;
        g_dumpconf_t            *dumpconf;
        g_access_t              *access;
        g_orphan_t              *orphan;
        g_ioctl_t               *ioctl;
        void                    *spare0;
        void                    *spare1;
        void                    *softc;
        unsigned                flags;
#define G_GEOM_WITHER           1
#define G_GEOM_VOLATILE_BIO     2
};

struct g_consumer and struct g_provider.
>How-To-Repeat:

>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:
_______________________________________________
freebsd-bugs@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-bugs
To unsubscribe, send any mail to "freebsd-bugs-unsubscr...@freebsd.org"

Reply via email to