2009/9/29 Marco van de Voort <mar...@stack.nl>:
>
> No.

So why is the function called MOVE instead of COPY?   :-)


I grep searched the *full* FPC source and found a implementation of
MemCopy() in the packages/pasjpeg/* directory...  So it seems to
confirm what you (Marco) said. MOVE = MEMCOPY.    It that case, MOVE
is a pretty stupid and confusing name for a procedure that actually
copies memory and not move memory. Just my 2c worth. ;-)

procedure MEMCOPY(dest, src : pointer; size : size_t);
begin
  Move(src^, dest^, size);
end;


Regards,
  - Graeme -


_______________________________________________
fpGUI - a cross-platform Free Pascal GUI toolkit
http://opensoft.homeip.net/fpgui/
_______________________________________________
fpc-pascal maillist  -  fpc-pascal@lists.freepascal.org
http://lists.freepascal.org/mailman/listinfo/fpc-pascal

Reply via email to