OS SSE support is now mandatory, so the description of --disable-sse
option isn't correct now (actually, it wasn't fully correct even before this).

 *Currently all it does is disables -msse2 flag*

The relevant parts of configure.ac:


AC_ARG_ENABLE(sse,
AC_HELP_STRING([--disable-sse], [Disable SSE if the OS does not support SSE instructions]),
[case "${enableval}" in
        yes) sse_os=yes ;;
        no)  sse_os=no ;;
        *) AC_MSG_ERROR(bad value ${enableval} for --enable-sse) ;;
esac],[sse_os=yes])


if test "x$asm_optimisation$sse_os" = "xyesyes" ; then
        XIPH_ADD_CFLAGS([-msse2])
        fi


So maybe it's better to rename it to --disable-sse2 or --disable-forced-sse2
or --no-force-sse2? (and rename 'sse_os' to 'use_sse2' or 'forced-sse2' ?)

Or least the description should be updated so that it reflects
the current function of this option.
_______________________________________________
flac-dev mailing list
flac-dev@xiph.org
http://lists.xiph.org/mailman/listinfo/flac-dev

Reply via email to