On Sun, Sep 08, 2019 at 01:53:12PM +0200, Moritz Barsnick wrote: > On Sat, Sep 07, 2019 at 16:20:35 -0400, Andriy Gelman wrote: > > > if (isPacked(c->srcFormat)) { > > > - src[0] = > > > - src[1] = > > > - src[2] = > > > - src[3] = src[0]; > > > - srcStride[0] = > > > - srcStride[1] = > > > - srcStride[2] = > > > - srcStride[3] = srcStride[0]; > > > > > + for ( int i = 0; i < 4; i++ ) { > > > > extra spaces and I guess you can start i from 1 > > I actually wonder what the original point was of assigning src[0] to > src[0]. it's cosmetics change, so I want to keep same logic with the old code. Maybe we can split the patch if the code isn't reasonable.
> > > > - if ( (uintptr_t)dst[0]&15 || (uintptr_t)dst[1]&15 || > > > (uintptr_t)dst[2]&15 > > > + if ((uintptr_t)dst[0]&15 || (uintptr_t)dst[1]&15 || > > > (uintptr_t)dst[2]&15 > > > || (uintptr_t)src[0]&15 || (uintptr_t)src[1]&15 || > > > (uintptr_t)src[2]&15 > > BTW, the original indentation was meant for alignment. OK, if for alignment, I'll adjust it. > > > > + for(int i = 0; i < 4; i++) > > "for (" is the correct style. OK, maybe I misunderstand. I'll update it. > > Moritz > _______________________________________________ > ffmpeg-devel mailing list > ffmpeg-devel@ffmpeg.org > https://ffmpeg.org/mailman/listinfo/ffmpeg-devel > > To unsubscribe, visit link above, or email > ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe". _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".