On Wed, Jan 23, 2019 at 3:31 AM Uoti Urpala <uoti.urp...@pp1.inet.fi> wrote:
>
> On Tue, 2019-01-22 at 15:35 -0300, James Almer wrote:
> > I'm not against renaming it to AV_ROUNDED_RSHIFT or similar, but other
> > than an entry in APIChanges we have no way to let library users that
> > RSHIFT will be removed two or so years from now.
>
> How about:
> static inline void __attribute__ ((deprecated)) RSHIFT_is_deprecated(void) {}
>
> #define RSHIFT(a, b) (RSHIFT_is_deprecated(), AV_ROUNDED_SHIFT(a, b))
>
I like this idear
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel