On Mon, Jan 21, 2019 at 21:32:46 -0500, FeRD wrote:
> Well... not *purely* cosmetic. See [1] for an example of one issue. Ruby's

> `ruby/config.h` header also defines an `RSHIFT` macro, with different
> semantics (it doesn't round), so when building code which includes
> both headers the macro ends up being redefined.
[...]
> [1]: https://github.com/OpenShot/libopenshot/issues/164

While I agree with the assessment that ffmpeg's macro should have been
named "FF_RSHIFT", "AV_RSHIFT" or even something more appropriate along
your suggestion, you failed to post an upstream patch with ruby to
rename their macro to "RUBY_RSHIFT". ;-) Honestly, these arbitrary
names (sometimes also public function names) really mess up inclusions.
(E.g. mutt moved from M_MACRONAME to MUTT_MACRONAME recently, for the
same reasons.)

Moritz
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to