On 7/8/2018 9:16 PM, myp...@gmail.com wrote: > On Sat, Jul 7, 2018 at 6:32 PM Carl Eugen Hoyos <ceffm...@gmail.com> wrote: >> >> 2018-07-07 7:48 GMT+02:00, Jun Zhao <mypopy...@gmail.com>: >>> use skip_bits when want to skip some bits. >>> >>> Signed-off-by: Jun Zhao <mypopy...@gmail.com> >>> --- >>> libavcodec/hevc_ps.c | 2 +- >>> 1 file changed, 1 insertion(+), 1 deletion(-) >>> >>> diff --git a/libavcodec/hevc_ps.c b/libavcodec/hevc_ps.c >>> index bc5406b..278b928 100644 >>> --- a/libavcodec/hevc_ps.c >>> +++ b/libavcodec/hevc_ps.c >>> @@ -1679,7 +1679,7 @@ int ff_hevc_decode_nal_pps(GetBitContext *gb, >>> AVCodecContext *avctx, >>> >>> if (get_bits1(gb)) { // pps_extension_present_flag >>> int pps_range_extensions_flag = get_bits1(gb); >>> - /* int pps_extension_7bits = */ get_bits(gb, 7); >>> + skip_bits(gb, 7); >> >> This seems to make the code less readable, no? > > You means keep old style? But I think skip_bits more clear in this > case, maybe I need to add some comment?
He probably means leaving the comment about what the skipped field/s is. _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel