On Fri, Feb 2, 2018, at 6:53 PM, James Almer wrote: > On 2/2/2018 12:23 PM, Josh de Kock wrote: > > > >> On 1 Feb 2018, at 18:51, Muhammad Faiz <mfc...@gmail.com> wrote: > >> > >>> On Thu, Feb 1, 2018 at 3:25 AM, Josh de Kock <j...@itanimul.li> wrote: > >>> Also replace linked list with an array. > >>> --- > >>> configure | 12 +- > >>> doc/APIchanges | 4 + > >>> libavcodec/.gitignore | 2 + > >>> libavcodec/allcodecs.c | 1473 > >>> ++++++++++++++++++++++++++++-------------------- > >>> libavcodec/avcodec.h | 31 + > >>> libavcodec/parser.c | 84 ++- > >>> libavcodec/utils.c | 112 ---- > >>> libavcodec/version.h | 3 + > >>> 8 files changed, 971 insertions(+), 750 deletions(-) > >>> > >> > >> I have a plan to sort codecs based on name and codec_id (which overlap > >> with this patch). Is it OK if I overtake this? > >> If it is not OK, I will wait until this patchset pushed. > >> > > > > I am unsure why you would need to sort codecs. The point of my patches is > > to bring the rest of ffmpeg up to the bsf iteration api (which abstracts > > internals away from the user). > > Doesn't bsf use next() and not iterate()?
It does but it doesn't really make sense to use _next when all the other _next functions dont work like bsf. I was contemplating whether I should rename the bsf api to use _iterate as well (i.e. deprecate current name, rename current functions, and have a function with the old names calling the new names). -- Josh _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel