2017-11-17 6:52 GMT+01:00 Li, Zhong <zhong...@intel.com>: >> > 2017-11-15 10:04 GMT+01:00 Zhong Li <zhong...@intel.com>: >> > > fix the compiling warning of "ignoring return value" >> > >> > > - ff_formats_ref(in_fmts, &ctx->inputs[0]->out_formats); >> > > - ff_formats_ref(out_fmts, &ctx->outputs[0]->in_formats); >> > > + if ((ret = ff_formats_ref(in_fmts, &ctx->inputs[0]->out_formats)) >> > > < 0) >> > > + return ret; >> > > + if ((ret = ff_formats_ref(out_fmts, >> > > + &ctx->outputs[0]->in_formats)) < >> > 0) >> > >> > Two additional lines are cheap. >> >> Just don't like any compiling warnings which may have potential issues >> just like this one. >> Personally speaking, I prefer to clear most of FFmpeg compiling warnings. > > Sorry, I may misunderstood due to miss some history discussion, here you > mean should be coding style making code clearer, right? Just like this: > "ret = ff_formats_ref(); > if (ret < 0) return ret;"
Yes, this is more readable. Thank you, Carl Eugen _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel