On 08/25/2017 05:35 PM, wm4 wrote:
+#define WIDTH(__ctx, __fmt) \
+    (V4L2_TYPE_IS_MULTIPLANAR((__ctx)->type) ? __fmt.fmt.pix_mp.width : 
__fmt.fmt.pix.width)
+
+#define HEIGHT(__ctx, __fmt) \
+    (V4L2_TYPE_IS_MULTIPLANAR((__ctx)->type) ? __fmt.fmt.pix_mp.height : 
__fmt.fmt.pix.height)
These names are a bit generic. Also, identifiers starting with __ are
always implementation reserved (i.e. using them undefined behavior).
You're forgetting to quote the __fmt macro parameter too.


ok, will just do inline functions instead. I shouldnt have done a macro...
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to