On Mon, 3 Apr 2017, Steven Liu wrote:
Use AVBprint to implementing av_strreplace add av_strreplace TEST_STRREPLACE
Thanks for keeping working on this. Agreeing with Nicolas, I also think it should be renamed to av_strireplace to reflect its case insensitivity.
Also the patch should be backported to 3.3. as well.
index 6438dbaede..f86798c69b 100644 --- a/libavformat/dashdec.c +++ b/libavformat/dashdec.c @@ -410,8 +410,10 @@ static char *get_content_url(xmlNodePtr *baseurl_nodes, int n_baseurl_nodes, xml } if (rep_bandwidth_val && tmp_str) url = av_strreplace(tmp_str, "$Bandwidth$", (const char*)rep_bandwidth_val); + if (tmp_str != url) av_free(tmp_str); + return url; }
Unrelated whitespace change... Thanks, Marton _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel