On 16/02/17 16:20, Michael Niedermayer wrote: > Its used elsewhere for 2^p-1 cliping > > Signed-off-by: Michael Niedermayer <mich...@niedermayer.cc> > --- > libavcodec/vaapi_encode_vp8.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/libavcodec/vaapi_encode_vp8.c b/libavcodec/vaapi_encode_vp8.c > index 4a1c85e66c..3d3831c46d 100644 > --- a/libavcodec/vaapi_encode_vp8.c > +++ b/libavcodec/vaapi_encode_vp8.c > @@ -161,12 +161,12 @@ static av_cold int > vaapi_encode_vp8_configure(AVCodecContext *avctx) > VAAPIEncodeContext *ctx = avctx->priv_data; > VAAPIEncodeVP8Context *priv = ctx->priv_data; > > - priv->q_index_p = av_clip(avctx->global_quality, 0, 127); > + priv->q_index_p = av_clip_uintp2(avctx->global_quality, 7); > if (avctx->i_quant_factor > 0.0) > - priv->q_index_i = av_clip((avctx->global_quality * > + priv->q_index_i = av_clip_uintp2((avctx->global_quality * > avctx->i_quant_factor + > avctx->i_quant_offset) + 0.5, > - 0, 127); > + 7); > else > priv->q_index_i = priv->q_index_p;
IMO this makes the code less readable, not more. It doesn't really matter to anything, though, so commit it if you really want to. (If this is mainly objecting to the magic number being visible there then please do introduce a constant to hide it rather than making the constant smaller - VP8_QINDEX_RANGE, say, to match <https://tools.ietf.org/html/rfc6386#section-14.1>.) _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel