On 08/01/17 19:27, Paul B Mahol wrote:
> On 1/8/17, Mark Thompson <s...@jkqxz.net> wrote:
>> +
>> +AVFilter ff_vf_deinterlace_vaapi = {
>> +    .name           = "deinterlace_vaapi",
>> +    .description    = NULL_IF_CONFIG_SMALL("Deinterlacing of VAAPI
>> surfaces"),
>> +    .priv_size      = sizeof(DeintVAAPIContext),
>> +    .init           = &deint_vaapi_init,
>> +    .uninit         = &deint_vaapi_uninit,
> 
> Why & here?

Explicitly taking the address of the function?  I weakly prefer this style, 
because the type isn't really matching otherwise (without it you are invoking 
an implicit conversion from "void f(void)" to "void (*f)(void)" or similar).

I can change it easily if you object.

Thanks,

- Mark
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to