On Fri, Feb 19, 2016 at 17:51:00 +0100, Nicolas George wrote:
> Changing the name of existing muxers is annoying, but for new features I
> would like much better if we did not wave around the name of a hash function
> that has known vulnerabilities since 20 years: "streamhash" would be an
> obvious choice.

md5enc is literally waiting to become "hashenc":

static const AVOption hash_options[] = {
    { "hash", "set hash to use", OFFSET(hash_name), AV_OPT_TYPE_STRING, {.str = 
"md5"}, 0, 0, ENC },
    { "format_version", "file format version", OFFSET(format_version), 
AV_OPT_TYPE_INT, {.i64 = 1}, 1, 1, ENC },
    { NULL },
};

Moritz
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
http://ffmpeg.org/mailman/listinfo/ffmpeg-devel

Reply via email to