Quoting James Almer (2024-03-28 04:12:09) > They will be useful to fill arrays stored in other structs. > > Signed-off-by: James Almer <jamr...@gmail.com> > --- > libavcodec/av1dec.c | 7 +-- > libavcodec/cri.c | 3 +- > libavcodec/decode.c | 99 +++++++++++++++++++++++++++-------------- > libavcodec/decode.h | 28 ++++++------ > libavcodec/dpx.c | 3 +- > libavcodec/h2645_sei.c | 4 +- > libavcodec/h264_slice.c | 3 +- > libavcodec/hevcdec.c | 6 ++- > libavcodec/libdav1d.c | 7 +-- > libavcodec/libjxldec.c | 3 +- > libavcodec/mjpegdec.c | 3 +- > libavcodec/mpeg12dec.c | 11 +++-- > libavcodec/pngdec.c | 8 ++-- > libavcodec/qsvdec.c | 4 +- > libavcodec/tiff.c | 3 +- > libavcodec/webp.c | 3 +- > 16 files changed, 120 insertions(+), 75 deletions(-)
Extra churn in all the decoders, longer and harder to read lines. Why not make ff_frame_new_side_data_from_buf() a wrapper for a new function instead? -- Anton Khirnov _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".