Quoting Roy Funderburk (2023-06-13 19:43:25) > > > On 6/13/23 7:26 AM, Paul B Mahol wrote: > > Why we need new av_* calls, can you elaborate logic behind such approach to > > implement parser? > > > There is common code for dtsuhd audio frame parsing (dtsuhd_common.c) used by > the libavcodec and libavformat DTS-UHD modules. It is complex enough that we > do not want to duplicate it. > > If you refer to the naming of av_*, would changing the names to ff_dtsuhd_* > as in libavcodec/aac_ac3_parser.c be more appropriate?
The difference between av* and ff* is not merely cosmetic - av-prefixed symbols are exported from shared objects [1]. Also do note that sharing structs across libraries opens you to various compatibility questions [2]. It might be easier to sidestep them by having a function in libavcodec that accepts AVCodecParameters and fills them according to the data, rather than pass codec-specific structs between libavformat and libavcodec. [1] http://ffmpeg.org/developer.html#Naming-conventions-1 [2] http://ffmpeg.org/developer.html#Library-public-interfaces -- Anton Khirnov _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".