Quoting Zhao Zhili (2022-09-23 19:46:24) > > > > -----Original Message----- > > From: ffmpeg-devel-boun...@ffmpeg.org <ffmpeg-devel-boun...@ffmpeg.org> On > > Behalf Of Rémi Denis-Courmont > > Sent: 2022年9月23日 22:35 > > To: ffmpeg-devel@ffmpeg.org > > Subject: Re: [FFmpeg-devel] [PATCH] avcodec/mjpegdec: fix -Wparentheses > > warning > > > > Le perjantaina 23. syyskuuta 2022, 20.40.30 EEST Zhao Zhili a écrit : > > > From: Zhao Zhili <zhiliz...@tencent.com> > > > > > > Signed-off-by: Zhao Zhili <zhiliz...@tencent.com> > > > --- > > > libavcodec/mjpegdec.c | 2 +- > > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > > > diff --git a/libavcodec/mjpegdec.c b/libavcodec/mjpegdec.c > > > index c594950500..d77c644d3b 100644 > > > --- a/libavcodec/mjpegdec.c > > > +++ b/libavcodec/mjpegdec.c > > > @@ -2866,7 +2866,7 @@ the_end: > > > } > > > } > > > > > > - if (e = av_dict_get(s->exif_metadata, "Orientation", e, > > > AV_DICT_IGNORE_SUFFIX)) { + if ((e = av_dict_get(s->exif_metadata, > > > "Orientation", e, AV_DICT_IGNORE_SUFFIX))) { char *value = e->value + > > > strspn(e->value, " \n\t\r"), *endptr; int orientation = strtol(value, > > > &endptr, 0); > > > > Isn't it easier to read if you break the assignment out, and use the result > > as > > predicate?? > > I prefer the coding style of splitting into two lines personally, but current > coding > Style is used everywhere in the code base, so I'm not sure.
Not everywhere, it depends on the author. I try to avoid assignments in conditions wherever possible, because they are hard to read IMO. -- Anton Khirnov _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".