What you say is true, IMHO, as long as the functions (in which the code is 
split) do really group logically related tasks and they have names that 
summarize what they are doing. In the examined case this is not true, see for 
example (in muxing.c):
static void open_video(AVFormatContext *oc, const AVCodec *codec, OutputStream 
*ost, AVDictionary *opt_arg)

The name "open_video" is too generic and it doesn't let the user know what the 
function is actually doing, without jumping from line to line in the code. In 
fact the function mixes different tasks: it opens the codec, it allocates a 
frame, it copies the stream parameters to the muxer. Same thing for 
write_audio_frame(), and in fact a comment is put just above the function, and 
it says:
"encode one audio frame and send it to the muxer,,,"
...which is obscure from the function's name (and, again, the user is forced to 
jump often from a chunk to another chunk of code in order to understand what 
the code is _generally_ doing).Note too that this can't be fixed by using more 
explicative or longer names, because the functions mixes tasks which are 
_different_.
Therefore, these functions in many cases do not improve readability and IMHO is 
better to have a longer code instead of forcing grouping different tasks in the 
same function with an ambiguous name.



   Il martedì 7 giugno 2022, 11:42:23 CEST, Anton Khirnov <an...@khirnov.net> 
ha scritto:  
 
 Quoting Paolo Prete (2022-06-06 19:40:42)
> Hello,
> From what I see, the doc/examples files can be still improved. More
> precisely, their main() is often split into functions with short names
> that hide important (sometime essential) details of what they're doing
> and they worsen the readability, by forcing the user to jump from
> chunks to chunks of the code.

I disagree VERY strongly.

Long functions are extremely hard to reason about, because of all the
pieces you have to keep in your head at once. Grouping logically related
blocks of code into their own small functions that can be thought of as
a single unit immensely improves readability and maintainability.

-- 
Anton Khirnov
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".
  
_______________________________________________
ffmpeg-devel mailing list
ffmpeg-devel@ffmpeg.org
https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

To unsubscribe, visit link above, or email
ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".

Reply via email to