Hendrik Leppkes: > On Sat, Oct 9, 2021 at 5:14 PM Andreas Rheinhardt > <andreas.rheinha...@outlook.com> wrote: >> >> Signed-off-by: Andreas Rheinhardt <andreas.rheinha...@outlook.com> >> --- >> libavformat/internal.h | 7 +++++++ >> libavformat/mux.c | 11 ++++++++++- >> 2 files changed, 17 insertions(+), 1 deletion(-) >> >> diff --git a/libavformat/internal.h b/libavformat/internal.h >> index 223befdbc0..867b5de514 100644 >> --- a/libavformat/internal.h >> +++ b/libavformat/internal.h >> @@ -760,6 +760,13 @@ int ff_add_attached_pic(AVFormatContext *s, AVStream >> *st, AVIOContext *pb, >> int ff_interleave_packet_per_dts(AVFormatContext *s, AVPacket *pkt, >> int flush, int has_packet); >> >> +/** >> + * Interleave packets directly in the order in which they arrive >> + * without any sort of buffering. >> + */ >> +int ff_interleave_packet_passthrough(AVFormatContext *s, AVPacket *pkt, >> + int flush, int has_packet); >> + > > The name seems inaccurate if its designed for a single stream and does > not in fact do any actual interleaving. >
The name stems from the fact that it is used as an interleavement function. And in 3/3 it is used in a scenario where there might be more than one stream. - Andreas _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".