On Tue, Dec 22, 2020 at 9:15 PM Lynne <d...@lynne.ee> wrote: > Dec 22, 2020, 19:09 by one...@gmail.com: > > > Signed-off-by: Paul B Mahol <one...@gmail.com> > > + > > +const URLProtocol ff_librist_protocol = { > > + .name = "rist", > > + .url_open = librist_open, > > + .url_read = librist_read, > > + .url_write = librist_write, > > + .url_close = librist_close, > > + .url_get_file_handle = librist_get_file_handle, > > + .priv_data_size = sizeof(RISTContext), > > + .flags = URL_PROTOCOL_FLAG_NETWORK, > > + .priv_data_class = &librist_class, > > +}; > > > > I think this will be affected by the rtmp/librtmp issue we had, where both > protocols shared a name and so couldn't be used alongside. So "librist" > would be better as a name. >
That would make this protocol implementation useless, as protocol is rist:// and not librist:// so would not automatically work iirc. _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".