On Tue, Apr 14, 2020 at 5:54 AM Jan Ekström <jee...@gmail.com> wrote: > > On Mon, Apr 13, 2020 at 3:20 PM Jun Zhao <mypopy...@gmail.com> wrote: > > > > From: Jun Zhao <barryjz...@tencent.com> > > > > add a new sidedata type for DOVI. > > > > Signed-off-by: Jun Zhao <barryjz...@tencent.com> > > --- > > libavcodec/avpacket.c | 1 + > > libavcodec/packet.h | 9 +++++++++ > > 2 files changed, 10 insertions(+) > > > > diff --git a/libavcodec/avpacket.c b/libavcodec/avpacket.c > > index ad020ee..675652d 100644 > > --- a/libavcodec/avpacket.c > > +++ b/libavcodec/avpacket.c > > @@ -396,6 +396,7 @@ const char *av_packet_side_data_name(enum > > AVPacketSideDataType type) > > case AV_PKT_DATA_ENCRYPTION_INFO: return "Encryption info"; > > case AV_PKT_DATA_AFD: return "Active Format > > Description data"; > > case AV_PKT_DATA_ICC_PROFILE: return "ICC Profile"; > > + case AV_PKT_DATA_DOVI_CONF: return "DOVI metadata"; > > } > > Unfortunately, I am not really able to quickly give this a full review > tonight, but at least this should be called similarly to what it is > called elsewhere. "DOVI configuration record" or so. The patch-set support DOVI Video Stream Descriptor for MPEG-TS format and Dolby Vision configuration box (DOVIDecoderConfigurationRecord) for MP4 format both, this is the reason to use a more general string "DOVI metadata" Anyway, I can change this part as the comment, wait more comments, tks > > Best regards, _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
To unsubscribe, visit link above, or email ffmpeg-devel-requ...@ffmpeg.org with subject "unsubscribe".