Stefano Sabatini <stefasab <at> gmail.com> writes: > > +extern uint64_t ff_MM_FIX_0_707106781; > > +extern uint64_t ff_MM_FIX_0_541196100; > > why do you need to change this? > > Can you just drop the ff_ prefix from the > constant and put it in the x86 file?
The reason is apparently llvm, see fa35ade8 My suggestion would be to ignore the issue for the port and test afterward if / when this was fixed. > > + ((short*)p->threshold_mtx)[a] = > > q * ((short*)p->threshold_mtx_noq)[a];//ints faster in C > > short -> int8_t (probably more readable) Sorry if I just misunderstand: I find both the comment in the code and your comment extremely difficult to understand. Carl Eugen _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel