> On Friday, September 19, 2014 12:31 PM, Carl Eugen Hoyos <ceho...@ag.or.at> > wrote:
> > Nicholas Robbins <nickrobbins-at-yahoo.com <at> ffmpeg.org> writes: > >> + { "only_dec_forced", "Only decode forced > subtitles", > > Please use the same option name as for pgs subtitles. > > Carl Eugen Ok, I'll do that. Also I noticed that dvdsubdec.c says: #define VD AV_OPT_FLAG_SUBTITLE_PARAM | AV_OPT_FLAG_DECODING_PARAM static const AVOption options[] = { { "palette", "set the global palette", OFFSET(palette_str), AV_OPT_TYPE_STRING, { .str = NULL }, 0, 0, VD } While pgssubdec.c says: #define SD AV_OPT_FLAG_SUBTITLE_PARAM | AV_OPT_FLAG_DECODING_PARAM static const AVOption options[] = { {"forced_subs_only", "Only show forced subtitles", OFFSET(forced_subs_only), AV_OPT_TYPE_INT, {.i64 = 0}, 0, 1, SD}, Shouldn't dvdsubdec have SD rather than VD for readability at least? Also, this requires the option be set by "-forced_subs_only 1". How does one implement boolean options so I could set it by "-forced_subs_only"? -Nick _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel