Hi, ----- Mail original ----- > Signed-off-by: Michael Niedermayer <michae...@gmx.at> > --- > libavformat/format.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/libavformat/format.c b/libavformat/format.c > index 828ab52..006cc87 100644 > --- a/libavformat/format.c > +++ b/libavformat/format.c > @@ -202,7 +202,7 @@ AVInputFormat *av_probe_input_format3(AVProbeData > *pd, int is_opened, > > fmt = NULL; > while ((fmt1 = av_iformat_next(fmt1))) { > - if (!is_opened == !(fmt1->flags & AVFMT_NOFILE)) > + if (!is_opened == !(fmt1->flags & AVFMT_NOFILE) && > strcmp(fmt1->name, "image2")) >
Wouldn't it be possible to add for instance another flag that tells this? AVFMT_PREFER_FILE or something like that (I don't like the name, just proposing so that what I say is clearer)? -- Ben _______________________________________________ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org http://ffmpeg.org/mailman/listinfo/ffmpeg-devel