On Mon, May 25, 2020 at 07:10:25PM -0300, Igor Ribeiro Barbosa Duarte wrote:
> Fix checkpatch error "WARNING: line over 80 characters" at cfg80211.c:451
> 
> Signed-off-by: Igor Ribeiro Barbosa Duarte <igor.ribeiro.dua...@gmail.com>
> ---
>  drivers/staging/wlan-ng/cfg80211.c | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/staging/wlan-ng/cfg80211.c 
> b/drivers/staging/wlan-ng/cfg80211.c
> index fac38c8..a911bcd 100644
> --- a/drivers/staging/wlan-ng/cfg80211.c
> +++ b/drivers/staging/wlan-ng/cfg80211.c
> @@ -447,9 +447,10 @@ static int prism2_connect(struct wiphy *wiphy, struct 
> net_device *dev,
>       /* Set the channel */
>       if (channel) {
>               chan = ieee80211_frequency_to_channel(channel->center_freq);
> -             result = prism2_domibset_uint32(wlandev,
> -                                             
> DIDMIB_DOT11PHY_DSSSTABLE_CURRENTCHANNEL,
> -                                             chan);
> +             result = prism2_domibset_uint32
> +                      (wlandev,
> +                       DIDMIB_DOT11PHY_DSSSTABLE_CURRENTCHANNEL,
> +                       chan);

The original really is easier to read and understand, don't you think
so?

Checkpatch is a hint, it doesn't always have to be followed exactly.
Perhaps that crazy #define could be shortened, or use a more
conventional name?

thanks,

greg k-h
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to