On Wed, 2018-10-03 at 22:43 +0200, Michael Straube wrote:
> Cleanup array declaration to clear two 'line over 80 characters'
> checkpatch warnings and improve readability.
[]
> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c 
> b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
[]
> @@ -3836,24 +3836,20 @@ Following are the initialization functions for WiFi 
> MLME
>  
> *****************************************************************************/
>  
>  static struct mlme_handler mlme_sta_tbl[] = {
> -     {WIFI_ASSOCREQ,         "OnAssocReq",   &OnAssocReq},
> -     {WIFI_ASSOCRSP,         "OnAssocRsp",   &OnAssocRsp},
> -     {WIFI_REASSOCREQ,       "OnReAssocReq", &OnAssocReq},
> -     {WIFI_REASSOCRSP,       "OnReAssocRsp", &OnAssocRsp},
> -     {WIFI_PROBEREQ,         "OnProbeReq",   &OnProbeReq},
> -     {WIFI_PROBERSP,         "OnProbeRsp",           &OnProbeRsp},
> -
> -     /*----------------------------------------------------------
> -                                     below 2 are reserved
> -     -----------------------------------------------------------*/
> -     {0,                                     "DoReserved",           
> &DoReserved},
> -     {0,                                     "DoReserved",           
> &DoReserved},
> -     {WIFI_BEACON,           "OnBeacon",             &OnBeacon},
> -     {WIFI_ATIM,                     "OnATIM",               &OnAtim},
> -     {WIFI_DISASSOC,         "OnDisassoc",           &OnDisassoc},
> -     {WIFI_AUTH,                     "OnAuth",               &OnAuthClient},
> -     {WIFI_DEAUTH,           "OnDeAuth",             &OnDeAuth},
> -     {WIFI_ACTION,           "OnAction",             &OnAction},
> +     {WIFI_ASSOCREQ,   "OnAssocReq",   &OnAssocReq},
> +     {WIFI_ASSOCRSP,   "OnAssocRsp",   &OnAssocRsp},
> +     {WIFI_REASSOCREQ, "OnReAssocReq", &OnAssocReq},
> +     {WIFI_REASSOCRSP, "OnReAssocRsp", &OnAssocRsp},
> +     {WIFI_PROBEREQ,   "OnProbeReq",   &OnProbeReq},
> +     {WIFI_PROBERSP,   "OnProbeRsp",   &OnProbeRsp},
> +     {0,               "DoReserved",   &DoReserved},
> +     {0,               "DoReserved",   &DoReserved},
> +     {WIFI_BEACON,     "OnBeacon",     &OnBeacon},
> +     {WIFI_ATIM,       "OnATIM",       &OnAtim},
> +     {WIFI_DISASSOC,   "OnDisassoc",   &OnDisassoc},
> +     {WIFI_AUTH,       "OnAuth",       &OnAuthClient},
> +     {WIFI_DEAUTH,     "OnDeAuth",     &OnDeAuth},
> +     {WIFI_ACTION,     "OnAction",     &OnAction},
>  };

Perhaps const here too, and as well, the struct
declaration could use const char * instead of char *



_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to