On Tue, Oct 06, 2015 at 06:42:13PM +0900, Tony Cho wrote:
> From: Leo Kim <leo....@atmel.com>
> 
> This patch remove typedef from the enum tenuWIDtype
> and rename it to WID_TYPE.
> 
> Signed-off-by: Leo Kim <leo....@atmel.com>
> Signed-off-by: Tony Cho <tony....@atmel.com>
> ---
>  drivers/staging/wilc1000/coreconfigurator.h | 2 +-
>  drivers/staging/wilc1000/host_interface.h   | 2 +-
>  drivers/staging/wilc1000/wilc_wlan_if.h     | 5 ++---
>  3 files changed, 4 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/staging/wilc1000/coreconfigurator.h 
> b/drivers/staging/wilc1000/coreconfigurator.h
> index 306efc9..02faf58 100644

[ snip ]

> diff --git a/drivers/staging/wilc1000/wilc_wlan_if.h 
> b/drivers/staging/wilc1000/wilc_wlan_if.h
> index 8fec64d..be972af 100644
> --- a/drivers/staging/wilc1000/wilc_wlan_if.h
> +++ b/drivers/staging/wilc1000/wilc_wlan_if.h
> @@ -315,7 +315,7 @@ typedef enum {
>       SW_TRIGGER_ABORT,
>  } TX_ABORT_OPTION_T;
>  
> -typedef enum {
> +enum WID_TYPE {

The enum name should be lowecase, i.e. 'enum wid_type'. 

>       WID_CHAR                = 0,
>       WID_SHORT               = 1,
>       WID_INT                 = 2,
> @@ -326,8 +326,7 @@ typedef enum {
>       WID_ADR                 = 7,
>       WID_UNDEF               = 8,
>       WID_TYPE_FORCE_32BIT    = 0xFFFFFFFF
> -
> -} WID_TYPE_T, tenuWIDtype;
> +};
>  
>  typedef enum {
>       WID_NIL                         = 0xffff,
> -- 
> 1.9.1

--
Sincerely yours,
Mike.
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to