On Tue, Jul 14, 2015 at 10:04 PM CEST, Mateusz Kulikowski 
<mateusz.kulikow...@gmail.com> wrote:
> Remove ack_policy enum and some unused RTL_DEBUG enums.
>
> Signed-off-by: Mateusz Kulikowski <mateusz.kulikow...@gmail.com>
> ---

[snip]

> diff --git a/drivers/staging/rtl8192e/rtllib_debug.h 
> b/drivers/staging/rtl8192e/rtllib_debug.h
> index 42e88d6..2f47a7c 100644
> --- a/drivers/staging/rtl8192e/rtllib_debug.h
> +++ b/drivers/staging/rtl8192e/rtllib_debug.h
> @@ -40,10 +40,7 @@ enum RTL_DEBUG {
>       COMP_DBG                = (1 << 1),
>       COMP_INIT               = (1 << 2),
>       COMP_RECV               = (1 << 3),
> -     COMP_SEND               = (1 << 4),
> -     COMP_CMD                = (1 << 5),
>       COMP_POWER              = (1 << 6),
> -     COMP_EPROM              = (1 << 7),
>       COMP_SWBW               = (1 << 8),
>       COMP_SEC                = (1 << 9),
>       COMP_LPS                = (1 << 10),
> @@ -58,15 +55,12 @@ enum RTL_DEBUG {
>       COMP_CH                 = (1 << 19),
>       COMP_RF                 = (1 << 20),
>       COMP_FIRMWARE           = (1 << 21),
> -     COMP_HT                 = (1 << 22),
>       COMP_RESET              = (1 << 23),
>       COMP_CMDPKT             = (1 << 24),
>       COMP_SCAN               = (1 << 25),
>       COMP_PS                 = (1 << 26),
>       COMP_DOWN               = (1 << 27),
>       COMP_INTR               = (1 << 28),
> -     COMP_LED                = (1 << 29),
> -     COMP_MLME               = (1 << 30),
>       COMP_ERR                = (1 << 31)
>  };

Is it possible that this change will make future readers wonder why
there are holes in the enum values, and hence hurts readability?

Cheers,
Jakub
_______________________________________________
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Reply via email to