Commit 22302af28d3f ("cleanup: Annotate guard constructors with
nonnull") added the macro __nonnull_args() to wrap raw compiler
attribute.Replace __attribute__((nonnull)) with __nonnull_args() to standardize nonnull attribute usage across the tree and keep the attribute's quirks in one place rather than open-coded at every call site. Suggested-by: Miguel Ojeda <[email protected]> Signed-off-by: Dmitry Ilvokhin <[email protected]> --- drivers/soc/aspeed/aspeed-lpc-snoop.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/soc/aspeed/aspeed-lpc-snoop.c b/drivers/soc/aspeed/aspeed-lpc-snoop.c index b09dca34099f..ee84a06a035e 100644 --- a/drivers/soc/aspeed/aspeed-lpc-snoop.c +++ b/drivers/soc/aspeed/aspeed-lpc-snoop.c @@ -226,7 +226,7 @@ static int aspeed_lpc_snoop_config_irq(struct aspeed_lpc_snoop *lpc_snoop, return 0; } -__attribute__((nonnull)) +__nonnull_args() static int aspeed_lpc_enable_snoop(struct device *dev, struct aspeed_lpc_snoop *lpc_snoop, struct aspeed_lpc_snoop_channel *channel, @@ -279,7 +279,7 @@ static int aspeed_lpc_enable_snoop(struct device *dev, return rc; } -__attribute__((nonnull)) +__nonnull_args() static void aspeed_lpc_disable_snoop(struct aspeed_lpc_snoop *lpc_snoop, struct aspeed_lpc_snoop_channel *channel) { -- 2.53.0-Meta
