Thank you for your contribution! Sashiko AI review found 1 potential issue(s) 
to consider:
- [Low] Typos in the commit message making it difficult to read.
--

--- Patch [3]: [PATCH v4 3/5] drm/i915/gem: Pull out size validation into a 
separate function ---
commit 1c3ac6d93ee48bc676608654e6e56d00b02a3262
Author: Krzysztof Karas <[email protected]>

drm/i915/gem: Pull out size validation into a separate function

This commit refactors shmem_sg_alloc_table by extracting the size validation
and page count assignment into a separate helper function to improve
readability.

>     shmem_sg_alloc_table is a very large and hard to read function,
>     so reduce the number of operations it is responsible for by
>     placing "size" validation ind "page_count" assignment n a new
>     helper.

[Severity: Low]
This isn't a bug, but there are a couple of typos here ("ind" instead of "and",
and "n" instead of "in").

-- 
Sashiko AI review ยท 
https://sashiko.dev/#/patchset/[email protected]?part=3

Reply via email to