Convert `use` imports to vertical layout for better readability and maintainability.
Signed-off-by: Guru Das Srinagesh <[email protected]> --- Came across a recent commit bc58905eb07 ("samples: rust_misc_device: use vertical import style") and found a few more locations that could benefit from this cleanup. No functional changes. Separating out patches per-subsystem as per the review feedback in [0]. Tested via: $ make LLVM=1 rustfmtcheck || echo "fail" $ [0]: https://lore.kernel.org/lkml/[email protected]/ --- drivers/gpu/drm/nova/file.rs | 10 ++++++++-- drivers/gpu/drm/nova/gem.rs | 11 +++++++++-- 2 files changed, 17 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/nova/file.rs b/drivers/gpu/drm/nova/file.rs index a3b7bd36792c..547da5caa58d 100644 --- a/drivers/gpu/drm/nova/file.rs +++ b/drivers/gpu/drm/nova/file.rs @@ -1,10 +1,16 @@ // SPDX-License-Identifier: GPL-2.0 -use crate::driver::{NovaDevice, NovaDriver}; +use crate::driver::{ + NovaDevice, + NovaDriver, // +}; use crate::gem::NovaObject; use kernel::{ alloc::flags::*, - drm::{self, gem::BaseObject}, + drm::{ + self, + gem::BaseObject, // + }, pci, prelude::*, uapi, diff --git a/drivers/gpu/drm/nova/gem.rs b/drivers/gpu/drm/nova/gem.rs index 9d8ff7de2c0f..8d8980425737 100644 --- a/drivers/gpu/drm/nova/gem.rs +++ b/drivers/gpu/drm/nova/gem.rs @@ -2,14 +2,21 @@ use kernel::{ drm, - drm::{gem, gem::BaseObject, DeviceContext}, + drm::{ + gem, + gem::BaseObject, + DeviceContext, // + }, page, prelude::*, sync::aref::ARef, }; use crate::{ - driver::{NovaDevice, NovaDriver}, + driver::{ + NovaDevice, + NovaDriver, // + }, file::File, }; --- base-commit: 78900738d981c97aad929e33620340d0d9bcfc82 change-id: 20260705-drm-vert-imp-8f4d1a46e4dc Best regards, -- Guru Das Srinagesh <[email protected]>
