On Tue, Apr 22, 2025 at 10:04:11AM -0700, Matthew Brost wrote: > From: Himal Prasad Ghimiray <himal.prasad.ghimi...@intel.com> > > This commit adds a new flag, devmem_only, to the drm_gpusvm structure. The > purpose of this flag is to ensure that the get_pages function allocates > memory exclusively from the device's memory. If the allocation from > device memory fails, the function will return an -EFAULT error. > > v3: > - s/vram_only/devmem_only/ > > Signed-off-by: Matthew Brost <matthew.br...@intel.com>
Reviewed-by: Matthew Brost <matthew.br...@intel.com> > Signed-off-by: Himal Prasad Ghimiray <himal.prasad.ghimi...@intel.com> > --- > drivers/gpu/drm/drm_gpusvm.c | 5 +++++ > include/drm/drm_gpusvm.h | 2 ++ > 2 files changed, 7 insertions(+) > > diff --git a/drivers/gpu/drm/drm_gpusvm.c b/drivers/gpu/drm/drm_gpusvm.c > index 38431e8360e7..edf107809d20 100644 > --- a/drivers/gpu/drm/drm_gpusvm.c > +++ b/drivers/gpu/drm/drm_gpusvm.c > @@ -1454,6 +1454,11 @@ int drm_gpusvm_range_get_pages(struct drm_gpusvm > *gpusvm, > goto err_unmap; > } > > + if (ctx->devmem_only) { > + err = -EFAULT; > + goto err_unmap; > + } > + > addr = dma_map_page(gpusvm->drm->dev, > page, 0, > PAGE_SIZE << order, > diff --git a/include/drm/drm_gpusvm.h b/include/drm/drm_gpusvm.h > index df120b4d1f83..9fd25fc880a4 100644 > --- a/include/drm/drm_gpusvm.h > +++ b/include/drm/drm_gpusvm.h > @@ -286,6 +286,7 @@ struct drm_gpusvm { > * @in_notifier: entering from a MMU notifier > * @read_only: operating on read-only memory > * @devmem_possible: possible to use device memory > + * @devmem_only: use only device memory > * > * Context that is DRM GPUSVM is operating in (i.e. user arguments). > */ > @@ -294,6 +295,7 @@ struct drm_gpusvm_ctx { > unsigned int in_notifier :1; > unsigned int read_only :1; > unsigned int devmem_possible :1; > + unsigned int devmem_only :1; > }; > > int drm_gpusvm_init(struct drm_gpusvm *gpusvm, > -- > 2.34.1 >