In preparation to introduce support for alternative output formats,
which will require extending hdmi_compute_format() functionality by
setting hdmi.output_bpc in addition to the current hdmi.output_format,
maintain future code readability by renaming the helper to
hdmi_compute_format_bpc().

There are no functional changes intended at this point.

Signed-off-by: Cristian Ciocaltea <cristian.ciocal...@collabora.com>
---
 drivers/gpu/drm/display/drm_hdmi_state_helper.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/display/drm_hdmi_state_helper.c 
b/drivers/gpu/drm/display/drm_hdmi_state_helper.c
index 
f54eb5c594cddbd67dfacb5e06d54e9ce7851013..160964190d82ac233fdbe34ac54024a007a19872
 100644
--- a/drivers/gpu/drm/display/drm_hdmi_state_helper.c
+++ b/drivers/gpu/drm/display/drm_hdmi_state_helper.c
@@ -605,10 +605,10 @@ hdmi_try_format_bpc(const struct drm_connector *connector,
 }
 
 static int
-hdmi_compute_format(const struct drm_connector *connector,
-                   struct drm_connector_state *conn_state,
-                   const struct drm_display_mode *mode,
-                   unsigned int bpc)
+hdmi_compute_format_bpc(const struct drm_connector *connector,
+                       struct drm_connector_state *conn_state,
+                       const struct drm_display_mode *mode,
+                       unsigned int bpc)
 {
        struct drm_device *dev = connector->dev;
 
@@ -639,7 +639,7 @@ hdmi_compute_config(const struct drm_connector *connector,
        int ret;
 
        for (bpc = max_bpc; bpc >= 8; bpc -= 2) {
-               ret = hdmi_compute_format(connector, conn_state, mode, bpc);
+               ret = hdmi_compute_format_bpc(connector, conn_state, mode, bpc);
                if (ret)
                        continue;
 

-- 
2.49.0

Reply via email to