> On 19 Feb 2025, at 17:23, Dave Airlie <airl...@gmail.com> wrote: > > On Thu, 20 Feb 2025 at 06:22, John Hubbard <jhubb...@nvidia.com> wrote: >> >> On 2/19/25 4:51 AM, Alexandre Courbot wrote: >>> Yes, that looks like the optimal way to do this actually. It also >>> doesn't introduce any overhead as the destructuring was doing both >>> high_half() and low_half() in sequence, so in some cases it might >>> even be more efficient. >>> >>> I'd just like to find a better naming. high() and low() might be enough? >>> Or are there other suggestions? >>> >> >> Maybe use "32" instead of "half": >> >> .high_32() / .low_32() >> .upper_32() / .lower_32() >> > > The C code currently does upper_32_bits and lower_32_bits, do we want > to align or diverge here? > > Dave. My humble suggestion here is to use the same nomenclature. `upper_32_bits` and `lower_32_bits` immediately and succinctly informs the reader of what is going on. — Daniel
- [RFC PATCH 0/3] gpu: nova-core: add basic timer s... Alexandre Courbot
- [PATCH RFC 1/3] rust: add useful ops for u64 Alexandre Courbot
- Re: [PATCH RFC 1/3] rust: add useful ops... Daniel Almeida
- Re: [PATCH RFC 1/3] rust: add useful... Alexandre Courbot
- Re: [PATCH RFC 1/3] rust: add us... Timur Tabi
- Re: [PATCH RFC 1/3] rust: a... Alexandre Courbot
- Re: [PATCH RFC 1/3] rus... John Hubbard
- Re: [PATCH RFC 1/3]... Alexandre Courbot
- Re: [PATCH RFC 1/3]... John Hubbard
- Re: [PATCH RFC 1/3]... Dave Airlie
- Re: [PATCH RFC 1/3]... Daniel Almeida
- Re: [PATCH RFC 1/3]... John Hubbard
- Re: [PATCH RFC 1/3]... Alexandre Courbot
- Re: [PATCH RFC 1/3]... Danilo Krummrich
- Re: [PATCH RFC 1/3] rus... Sergio González Collado
- Re: [PATCH RFC 1/3] rust: add useful ops... Sergio González Collado
- Re: [PATCH RFC 1/3] rust: add useful ops... Dirk Behme
- Re: [PATCH RFC 1/3] rust: add useful... Alexandre Courbot
- Re: [PATCH RFC 1/3] rust: add us... Dirk Behme
- [PATCH RFC 3/3] gpu: nova-core: add basic ti... Alexandre Courbot
- [PATCH RFC 2/3] rust: make ETIMEDOUT error a... Alexandre Courbot