On 11/15/2024 1:22 PM, Easwar Hariharan wrote: > secs_to_jiffies() is defined in hci_event.c and cannot be reused by > other call sites. Hoist it into the core code to allow conversion of the > ~1150 usages of msecs_to_jiffies() that either: > > - use a multiplier value of 1000 or equivalently MSEC_PER_SEC, or > - have timeouts that are denominated in seconds (i.e. end in 000) > > It's implemented as a macro to allow usage in static initializers. > > This will also allow conversion of yet more sites that use (sec * HZ) > directly, and improve their readability. > > Suggested-by: Michael Kelley <mhkli...@outlook.com> > Signed-off-by: Easwar Hariharan <eahar...@linux.microsoft.com> > Signed-off-by: Thomas Gleixner <t...@linutronix.de> > Reviewed-by: Luiz Augusto von Dentz <luiz.von.de...@intel.com> > Link: > https://lore.kernel.org/all/20241030-open-coded-timeouts-v3-1-9ba123fac...@linux.microsoft.com
your signed-off-by should be last. and you have a patch ordering problem since this patch must come before all the patches that use secs_to_jiffies(), otherwise this series cannot be bisected