> >     /* wait the flip take affect.*/
> > -   timeout = wait_for_completion_timeout(flip_done, HZ);
> > -   if (timeout == 0) {
> > +   time_left = wait_for_completion_timeout(flip_done, HZ);
> > +   if (time_left == 0) {
> 
> Honestly, if the name of the variable is confusing I would get rid of it 
> completely. Can you
> send a patch that removes the timeout variable and here just does:
> 
>       if (wait_for_completion_timeout(flip_done, HZ) == 0) {

Can do. I think, though, that using 'time_left' is still easier to
understand. However, this code block is simple enough and it is your
driver, so I'll send v2 later.

Attachment: signature.asc
Description: PGP signature

Reply via email to