Use the resource_size() function instead of a open coded computation
resource size. It makes the code more readable.

Issue identified using resource_size.cocci coccinelle semantic patch.

Signed-off-by: Deepak R Varma <d...@mailo.com>
---
Note: Proposed change compile tested only.

 drivers/gpu/drm/amd/amdkfd/kfd_migrate.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c 
b/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c
index 10048ce16aea..de8ce72344fc 100644
--- a/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c
+++ b/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c
@@ -1027,8 +1027,7 @@ int svm_migrate_init(struct amdgpu_device *adev)
                /* Disable SVM support capability */
                pgmap->type = 0;
                if (pgmap->type == MEMORY_DEVICE_PRIVATE)
-                       devm_release_mem_region(adev->dev, res->start,
-                                               res->end - res->start + 1);
+                       devm_release_mem_region(adev->dev, res->start, 
resource_size(res));
                return PTR_ERR(r);
        }

--
2.34.1



Reply via email to