On Fri, 05 Aug 2022, ChiaEn Wu wrote: > From: ChiYuan Huang <cy_hu...@richtek.com> > > This adds support for the MediaTek MT6370 SubPMIC. MediaTek MT6370 is a > SubPMIC consisting of a single cell battery charger with ADC monitoring, > RGB LEDs, dual channel flashlight, WLED backlight driver, display bias > voltage supply, one general purpose LDO, and the USB Type-C & PD controller > complies with the latest USB Type-C and PD standards. > > Reviewed-by: Andy Shevchenko <andy.shevche...@gmail.com> > Signed-off-by: ChiYuan Huang <cy_hu...@richtek.com> > Signed-off-by: ChiaEn Wu <chiaen...@richtek.com> > --- > > v7 > - Move '#define MT6370_REG_MAXADDR' to the next line of > '#define MT6370_REG_CHG_MASK1' > - Rename 'MT6370_REG_ADDRLEN' to 'MT6370_MAX_ADDRLEN' > --- > drivers/mfd/Kconfig | 16 +++ > drivers/mfd/Makefile | 1 + > drivers/mfd/mt6370.c | 312 > +++++++++++++++++++++++++++++++++++++++++++++++++++ > drivers/mfd/mt6370.h | 99 ++++++++++++++++ > 4 files changed, 428 insertions(+) > create mode 100644 drivers/mfd/mt6370.c > create mode 100644 drivers/mfd/mt6370.h
Applied, thanks. -- DEPRECATED: Please use l...@kernel.org