On Tue, Jul 13, 2021 at 9:33 PM Sam Ravnborg <s...@ravnborg.org> wrote: > > Make it obvious that mode_fixup is deprecated and new drivers shall use > atomic_check. > > Signed-off-by: Sam Ravnborg <s...@ravnborg.org> > Cc: Laurent Pinchart <laurent.pinch...@ideasonboard.com> > Cc: Andrzej Hajda <a.ha...@samsung.com> > Cc: Maarten Lankhorst <maarten.lankho...@linux.intel.com> > Cc: Maxime Ripard <mrip...@kernel.org> > Cc: Thomas Zimmermann <tzimmerm...@suse.de> > Cc: David Airlie <airl...@linux.ie> > Cc: Daniel Vetter <dan...@ffwll.ch> > --- > include/drm/drm_bridge.h | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h > index 46bdfa48c413..668f14234459 100644 > --- a/include/drm/drm_bridge.h > +++ b/include/drm/drm_bridge.h > @@ -136,6 +136,9 @@ struct drm_bridge_funcs { > * > * NOTE: > * > + * This is deprecated, do not use! > + * New drivers shall use &drm_bridge_funcs.atomic_check.
Bit a bikeshed, but in the rendered text this will be one line, I'd just merge it. Also since this is a reference within the same struct just use @atomic_check. Now the real review: There's a pile more of these in drm_modeset_helper_vtables.h (well in crtc and encoder funcs, so only two, a small pile). Can you pls fix those up too? With that: Reviewed-by: Daniel Vetter <daniel.vet...@ffwll.ch> > + * > * This function is called in the check phase of atomic modesets, > which > * can be aborted for any reason (including on userspace's request to > * just check whether a configuration would be possible). Drivers MUST > -- > 2.30.2 > -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch