Hi Tomi and Sebastian,

Thank you for the patch.

On Thu, Nov 05, 2020 at 02:03:13PM +0200, Tomi Valkeinen wrote:
> From: Sebastian Reichel <sebastian.reic...@collabora.com>
> 
> Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: Sebastian Reichel <sebastian.reic...@collabora.com>
> Signed-off-by: Tomi Valkeinen <tomi.valkei...@ti.com>
> ---

Reviewed-by: Laurent Pinchart <laurent.pinch...@ideasonboard.com>

>  drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c 
> b/drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c
> index 3668b3f0aff2..5159dd51a353 100644
> --- a/drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c
> +++ b/drivers/gpu/drm/omapdrm/displays/panel-dsi-cm.c
> @@ -219,7 +219,7 @@ static const struct backlight_ops dsicm_bl_ops = {
>       .update_status  = dsicm_bl_update_status,
>  };
>  
> -static ssize_t dsicm_num_errors_show(struct device *dev,
> +static ssize_t num_dsi_errors_show(struct device *dev,
>               struct device_attribute *attr, char *buf)
>  {
>       struct panel_drv_data *ddata = dev_get_drvdata(dev);
> @@ -239,7 +239,7 @@ static ssize_t dsicm_num_errors_show(struct device *dev,
>       return snprintf(buf, PAGE_SIZE, "%d\n", errors);
>  }
>  
> -static ssize_t dsicm_hw_revision_show(struct device *dev,
> +static ssize_t hw_revision_show(struct device *dev,
>               struct device_attribute *attr, char *buf)
>  {
>       struct panel_drv_data *ddata = dev_get_drvdata(dev);
> @@ -259,8 +259,8 @@ static ssize_t dsicm_hw_revision_show(struct device *dev,
>       return snprintf(buf, PAGE_SIZE, "%02x.%02x.%02x\n", id1, id2, id3);
>  }
>  
> -static DEVICE_ATTR(num_dsi_errors, S_IRUGO, dsicm_num_errors_show, NULL);
> -static DEVICE_ATTR(hw_revision, S_IRUGO, dsicm_hw_revision_show, NULL);
> +static DEVICE_ATTR_RO(num_dsi_errors);
> +static DEVICE_ATTR_RO(hw_revision);
>  
>  static struct attribute *dsicm_attrs[] = {
>       &dev_attr_num_dsi_errors.attr,

-- 
Regards,

Laurent Pinchart
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to