On 23/02/2020 3:07 pm, Heiko Stuebner wrote:
[...]
+#define dsi_generic_write_seq(dsi, cmd, seq...) do {                   \
+               static const u8 d[] = { seq };                          \
+               int ret;                                                \
+               ret = mipi_dsi_dcs_write(dsi, cmd, d, ARRAY_SIZE(d));   \

Nit: in the rocktech driver, dsi_generic_write_seq() is wrapping mipi_dsi_generic_write() which seems logically self-consistent. Therefore shouldn't this wrapper be called something like dsi_dcs_write_seq()? I have no idea what any of this actually means, but the dissonance is enough to make my reviewer-sense tingle ;)

Robin.

+               if (ret < 0)                                         \
+                       return ret;                                     \
+       } while (0)
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to