From: Artur Świgoń <a.swi...@partner.samsung.com>

This patch improves code readability by changing the following construct:

>    if (cond)
>        goto passive;
>    foo();
>    goto out;
>passive:
>    bar();
>out:

into this:

>    if (cond)
>        bar();
>    else
>        foo();

Signed-off-by: Artur Świgoń <a.swi...@partner.samsung.com>
---
 drivers/devfreq/exynos-bus.c | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)

diff --git a/drivers/devfreq/exynos-bus.c b/drivers/devfreq/exynos-bus.c
index f85bed241631..60ad4319fd80 100644
--- a/drivers/devfreq/exynos-bus.c
+++ b/drivers/devfreq/exynos-bus.c
@@ -420,19 +420,13 @@ static int exynos_bus_probe(struct platform_device *pdev)
                goto err_reg;
 
        if (passive)
-               goto passive;
+               ret = exynos_bus_profile_init_passive(bus, profile);
+       else
+               ret = exynos_bus_profile_init(bus, profile);
 
-       ret = exynos_bus_profile_init(bus, profile);
        if (ret < 0)
                goto err;
 
-       goto out;
-passive:
-       ret = exynos_bus_profile_init_passive(bus, profile);
-       if (ret < 0)
-               goto err;
-
-out:
        max_state = bus->devfreq->profile->max_state;
        min_freq = (bus->devfreq->profile->freq_table[0] / 1000);
        max_freq = (bus->devfreq->profile->freq_table[max_state - 1] / 1000);
-- 
2.17.1

Reply via email to